Wednesday, 18 March 2015

6900 & 7800 Series Phone Directories Failing

Sadly the 7800 series phones have multiple known issues with directories (e.g. CSCuq12291 & CSCus20047), resulting in the Personal Directory and Corporate Directory displaying "host not found". I encountered this during a large deployment of 7821 & 7841 phones with CUCM 10.5(2), Cisco TAC issued an engineering special firmware (78xx.10-2-1ES6-1) which failed to resolve the problem. Eventually the problem was resolved by manually editing the service URLs for Personal Directory and Corporate Directory from the default values.

DirectoryDefault valueAmended value
Corporate DirectoryApplication:Cisco/CorporateDirectoryhttp://10.15.0.2:8080/ccmcip/xmldirectoryinput.jsp
Personal DirectoryApplication:Cisco/PersonalDirectoryhttp://10.15.0.2:8080/ccmpd/pdCheckLogin.do?

Put your publisher IP address into the amended service URL, click save, click update subscription & then reset your phones.
To avoid affecting other phones I did try setting these URLs in Enterprise Parameters & then setting the 7821/7841 phones to use external service provisioning, however they don't seem to support external service provisioning & thus get stuck showing "requesting". Fortunately using the amended service URLs have no negative affect on other models of phone.

Update: I also recently experienced this exact same issue with 6900 series phones after doing an upgrade to CUCM 10.5(2), fortunately updating the service URLs also fixed the problem.

3 comments:

  1. Genius thanks saved me hours. I owe you a beer ;-)

    ReplyDelete
  2. In my case it only works if you explicitly set the Service Provisioning to "Internal" on the Phone.

    ReplyDelete